Windows mapped drives


#21

Run services.msc and find the sickrage service. Double click the service and on the log on tab change it from local system to a user that has permission to view the share i.e. the account you use to log on to the machine. Stop the service and start it again for the change to take effect. Using the format \server\share should then work…that’s 2 slashes before the server for some reason it keeps taking the first slash off

This doesn’t work, when I use this method the data just gets stored on the local path \server\share. A new folder is created on c:\ with the name of the server I would like to access the data on.


#22

You have to use 2 leading slashes “\server\share” something keeps deleting the first slash before server from my post

If you can access the share in file explorer then changing the service to use your windows login will work


#23

I already mentioned it tried that, didn’t work.


#24

Did you stop and restart the service?


image


image


#25

Like I said, I have tried this.

I don’t know what version of Sickrage you are on but the one I am on simply doesnt even accept UNC paths as valid input for fields where paths are asked.

I am on the latest Windows Installer version: SR 9.3.96

image


#26

me too

I used the browse button in sickrage and typed in the path


#27

Figured out the problem.

Since MS changed a lot of things regarding sharing in Windows 10 you are no longer able to share locations between Windows 10 devices without actively performing authentication (i.e. even the most unsecured form of sharing folders between devices requires you to type in ‘guest’ as username. Since SR doesn’t support providing credentials this lead to the service not being able to authenticate.).

Since I’m not working with a domain situation I had to figure out a way to authenticate my SR-running installation to my file-serving installation. With homegroups also being out the door in W10 1803 there aren’t many options left.

The solution I found to work was to change my device local sign into ‘Microsoft Account sign-in’ on both devices. With the same account existing on both devices I was able to grant share permission to this user and consume that permission from SR by running the SR service under that same account.

tl;dr

Use “Microsoft Account sign-in” on all devices if you are running a modern installations of Windows 10 to circumvent the need to provide credentials when connecting to a UNC path.

Obviously this only applies when using stand-alone W10 devices; when using a NAS or domain based file services this solution does not apply.


#28

You can also use Group policy to allow unauthenticated shares if your using a pro version of Windows 10. Thats how mine is setup. I had totally forgotten about that, sorry. I am Happy to hear you got it working


#29

Ok, I got it working too.
As suggested, I changed the SR service to run as the same user that I use to log into my PC.
All working now, and I was able to set the UNC path via the web UI, not by editing config.ini.
Not as secure as I’d like I guess, but then it’s in a fairly contained home network, so not too much of an issue.
Thanks for the help everyone!


#30

Actually this is exactly why I implemented the SSO system, to add a nice layer of security to the app it self :slight_smile:


#31

Thanks Cablemage, this worked for me


#32

I believe that this has something to do with the account that the service is starting with and whether or not there is an associated account on the NAS that has access to the directories that you are trying to access. I believe that this was the case before, but I could be mistaken.


#33

That resolved it for me as well. Thank you


#34

I cannot get networked drives to show up. I login with the same credentials as administrator on all computers in my network. I tried to set my user name in the Sickrage service but still no joy. The old version of Sickrage does not have this problem. I was forced to the new version several weeks ago when my computer crashed. I liked the old version much better. Is there a way to go back to it as it had very few issues but worked good enough for me?
I am running Windows 10 Pro 1809

EDIT I did get it to work by using the UNC address but would still really prefer to see the networked drives.

Thanks


#35

Aside for the network drive issue what else does need to work properly for you, If you can provide more detail I can resolve the problems


#36

I have 566 TV shows on my Plex server mostly kept updated via Sickrage. It works most of the time but have different problems from time to time. Let me start first with the new version and what just now happened to me.

I just tried to update one show that is located on the network share. Changing to the network drive was successful via UNC and no longer says missing. 2 episodes already on the share are showing as wanted. I tried to re-scan and also Full Update but Sickrage will not see them. Previously with the old version when I did this the shows would show up and then I would do a preview rename and they would show up perfectly. That is not happening now.

This brings up one of my other issues. That being when changing a shows status sometimes the only way to change is first change to ignored then change to the new status.

#37

What are the filenames of the 2 episodes not showing up when trying to do a refresh or full update ?


#38

Chicago Fire - S07E13 -The Plunge and Chicago Fire - S07E14

Also there status is Wanted but when I tried to make them show as Downloaded Unknown I could not until I first made them Ignored then I could make them Downloaded Unknown.

Sorry I didn’t see your question yesterday. I thought I would get an email notification when you answered but I did not.


#39

Those are the exact filenames ? where are the extensions ?


#40

The extensions are .mkv I copied and pasted the file names.