Windows mapped drives


#1

I am trying to add existing shows to a new install of sickrage. I used the newest windows installer, as of yesterday and checked for updates to make sure I’m on the latest version. Under general config I added the root directory for all my tv shows on my NAS. This path works if I plug it in to file explorer but not in sickrage. When I go to add existing shows and check the box to use it as the search directory nothing ever shows up. Any ideas?


#2

how are you entering the path and what version are you on ?


#3

Here’s my version info and a screenshot of my folder entries. Those file paths work perfectly in windows explorer.

Branch: master

Commit: 51328d1fb61ebc9704934e3cf14425453196790d
Version: v2018.09.17-1
Database Version: 44.0


#4

Sorry but you’re using a version that is not officially supported, official version of SR are located at https://www.sickrage.ca for download.

Thanks!


#5

Ok when I install the latest windows installer and try to add those paths they don’t show up at all in the list after clicking ok. What format are they supposed to go in as?


#6

The format should be this \\network\share or you could try and map the network share to a drive letter as well and then use that, are you logged in with Administrator privs ?


#7

I’m logged in as admin, that’s how it’s formated and my mapped drive letters do not show up. Only local drives. Any other thoughts?


#8

I have even tried creating a sym link on a local drive and I can browse that folder on the local drive correctly but sickrage gives a warning that the directory cannot be read.


#9

I have the same issue. Fresh install of SickRage on Windows 10 1809. SickRage service is running with admin account. SickRage only sees local drives, it does not see any mapped drives. it does, however allow me to enter the show root folder paths as “\server\folder”, so I have been able to add my existing shows.


#10

I’ll look into the mapped drive issues later on tonight, glad you got to add you’re existing shows :slight_smile:


#11

same issue for me. Fresh install on W10. I can see my two local drives, and I can enter a network location (\ \nas\media\tv\shows…) but it won’t read the files there.
I replaced the account that is running the SR service with a new account, granted admin permissions, and even gave it a netlogon script to map the network drive directly. confirmed that this is working, but SR service still can’t get there.


#12

I’ll need to look further into this, on way home now


#13

just to add some more info to this: my fresh install was on a PC that had a very old version of SR installed (which wasn’t updating anymore). The old version was able to access the NAS no issues. I completely uninstalled and then downloaded and installed the new version, and it can’t connect.


#14

Haven’t forgotten about this, just been slammed with a dozen other fixes, will get to this next tonight :slight_smile:


#15

This is exactly the same scenario I ran into.


#16

Still working on this …


#17

just wondering any progress on this? do you need any info/logs that will help to debug? thanks!!


#18

you have to put the directory direct into the config.ini, plus make sure that you go into services and stop sickrage or it will not save.
root_dirs = o, \core\core\media\tv
must have the 0, in front
this is for the new version of sickrage


#19

Also experiencing this issue on Windows 10.

Tried:

  • Mapping the drive to a driveletter
  • Creating symlink on c:\
  • Using UNC path
  • Disabling password authentication on network share
  • Running sickrage under the same user that has the drives mapped.

Nothing seems to do the trick.

Any updates?


#20

Run services.msc and find the sickrage service. Double click the service and on the log on tab change it from local system to a user that has permission to view the share i.e. the account you use to log on to the machine. Stop the service and start it again for the change to take effect. Using the format \server\share should then work…that’s 2 slashes before the server for some reason it keeps taking the first slash off

I had to use the windows version like this while I was getting my freenas install running correctly