Upgrade to ReadyNAS 6.10.0 Hotfix 2 uninstalled SR

I upgraded my ReadyNAS 214 box on Thursday night (4/25) to the latest update, 6.10.0 Hotfix 2. The upgrade appears to have run fine. The server restarted that night, but I don’t remember checking if Sickrage was up or not.

Not sure if it is related to the upgrade or not, but I tried to log on to my NAS Sickrage Friday night and I got a message that the site wasn’t available. I logged on to the NAS via SSH and the only directory under /apps/sickrage is app-config. Under the logs directory was sickrage.log and it appears to have last updated right around the same time as the ReadyNAS upgrade:
-rw-r–r-- 1 admin admin 669797 Apr 25 19:55 sickrage.log

I’m just not sure what happened to the rest of the files, but they are gone. No “bin” directory, nothing.

I tried re-installing from the 2018.11.10 version, using the ReadyNAS app installation interface, and it ran for 30+ minutes and never finished. I refreshed and tried to restart and it gives me an error trying to restart.

So:

  1. Any idea why SR uninstalled?
  2. Any logs I can look at?
  3. How do I reinstall?

Thanks!

@echel0n, any idea what’s going on here?

Is there a new version for ReadyNAS available to try to install?

I’ve been without my SR installation for almost a month now, and I’m really starting to miss it! :slight_smile:

Does ReadyNAS support running Docker images ?

No idea. I’m not familiar with Docker. The ReadyNAS box I have (214) is an ARM box, if that helps. A quick search seems to indicate it’s not supported.

I’m fine with not upgrading, but how do I re-install? The original version I had was fine. I’m OK not to upgrade. I’d just like to get back to the previous version at least.

Does it support Python 3 ?

No idea. I can’t really find any info about that. Appears to be running 2.7.9 currently.