Update Issue on Synology Sickarge


#1

Hi,

i have an update issue and this message

2019-04-07 15:20:56 VERSIONUPDATER::Unable to update requirements using /volume1/@appstore/sickrage/share/SiCKRAGE/requirements.txt

in this file i have

APScheduler == 3.5.3
babelfish == 0.5.5
bencode == 1.0
CacheControl == 0.12.5
cfscrape == 1.9.5
configobj == 5.0.6
feedparser == 5.2.1
guessit == 3.0.3
hachoir_core == 1.3.3
hachoir_metadata == 1.3.3
hachoir_parser == 1.3.4
jsonrpclib == 0.1.7
Mako == 1.0.7
markdown2 == 2.3.6
oauth2 == 1.9.0.post1
profilehooks == 1.10.0
Send2Trash == 1.5.0
six == 1.11.0
subliminal == 2.0.5
tornado == 5.1.1
xmltodict == 0.11.0
MultipartPostHandler == 0.1.0
beautifulsoup4 == 4.6.3
python_dateutil == 2.7.5
pynzb == 0.1.0
futures == 3.2.0
gntp == 1.0.3
python_twitter == 3.5
pyxdg == 0.26
urllib3 == 1.24.1
lockfile == 0.12.2
requests == 2.20.1
codernitydb == 0.5.0
fake-useragent == 0.1.11
html5lib == 1.0.1
arrow == 0.12.1
unidecode == 1.0.23
twilio == 6.21.0
chardet == 3.0.4
pytz == 2018.7
tzlocal == 2.0.0b1
raven == 6.9.0
python-keycloak-client == 0.2.2
simplejson == 3.16.0
service_identity == 17.0.0
certifi
pyasn1
lxml
ipaddress
psutil
cffi

How update Sickrage ?

Rgds
Akhlan


#2

Do you have you’re pip path set in settings > general > advanced ?

I wouldn’t worry to much about this as I’ll be releasing the new Python 3 version in less then a month, the update will go out as a package updatable via Synology’s package manager, that’ll make this issue mute.


#3

I don’t know what put in this filed

my python 2.7.14 is located here

/volume1/@appstore/python/

(if it’s a problem, I can wait one month :wink: )