Unable to update Provider URL

The torrent provider changed its domain from ncore.cc to ncore.pro.
I’ve tried to update the /opt/sickrage/sickrage/search_providers/torrents/ncore.py file like so:
super().init(‘nCore’, ‘https://ncore.pro’, True)
After that I deleted the cache files from the /config folder and restarted the docker container.
Somehow the requests still target the ncore.cc domain.

I had already tried to set the self._urls and switch the {base_url} string to ‘https://ncore.pro’ so essentially burn in the domain but there was no change, still targeting ncore.cc

I had tried to disable ‘SiCKRAGE API extra features’ at Settings → General → Advanced Settings, but there was no change either.

I had tried to assign the new domain inside the ‘login’ and ‘search’ methods directly, but no luck, still ncore.cc

What else should I do to update the URL, please advise!
Thanks in advance!

ok, I’ve made the URL change on our backend, should be fine now, I suggest reverting all your changes back to stock, also next time just ask and we will take care of it for you.

thanks!

1 Like