TVDB search returns 401 Unauthorised

I’m unable to search on the TVDB for a series.
I am getting 401 Unauthorised errors.

2021-10-07 18:48:21 DEBUG::WEB-Thread_0::Series search using query term CSI:Vegas returned zero results, cannot find series on TheTVDB
2021-10-07 18:48:21 DEBUG::WEB-Thread_0::SiCKRAGE API response returned for url https://www.sickrage.ca/api/v6/series-provider/thetvdb/search/CSI%3AVegas/eng Response: Unauthorized, Code: 401

Also doing a “Provider Status” check returns a whole lot of 401 Unauthorised errors.
2021-10-07 18:50:19 DEBUG::WEB-Thread_0::SiCKRAGE API response returned for url https://www.sickrage.ca/api/v6/provider/rarbg/status Response: Unauthorized, Code: 401

For example.

So please advise as to how I can resolve these errors?
I assume I have to create / update credentials of some kind to do this?

I’m running the following: SR Version:
10.0.45

SR Install Type:
WINDOWS

Tornado Version:
6.1

Python Version:
3.7.6 (tags/v3.7.6:43364a7ae0, Dec 18 2019, 23:46:00) [MSC v.1916 32 bit (Intel)]

Have you tried logging out and then back in to SR ?

Hi,

I’ve just tried that but now it’s very very slow to get anywhere.
It’s possible I may have changed some Network Settings pertaining to the type of login and such. (Local vs SSO etc and I cannot recall what the defaults are any more.

Is there a way to reset these settings?
Or maybe just a list of the defaults?

Hi,
OK so what I’ve ended up doing is:
Change my Network settings back to login via SSO to the auth.sickrage.ca endpoint.

This I think I changed to a Local Login because I was having issues with the SSO server a while back and at that point it was not 100% necessary to get an Auth Token from the auth.sickrage.ca service as most things were local to provider endpoint.

However this is now not the case so I’ll need to login via SSO from now on.

Thanks for the reply.

1 Like

Was just going to say you might want to re-enable SSO to that you pull down a oauth2 token that will then get exchanged for an API key, after that you can disable SSO if you want to but I would advise just leaving it enabled to avoid issues like this in the future.

Glad its working for you now!

1 Like