SR ReadyNas 404 Client Error


#16

No not so weird. I just had the exact same situation (I think). RN312 running 6.10.0-T181

  • I had the 2018.02.17-ml0 version installed
  • I dled and uploaded sickrage_2018.10.13_amd64.deb. Docker CE CLI was also installed.
  • Wait, reboot etc. Error message about install. Sickrage wont start
  • Cant uninstall by dashboard.

I had to go in using WinSCP and delete the directory from /apps. Then I could reinstall the 2018.02.17-ml0 version from the app store again.

Also, currently on that version (which is running fine), I get There is a [newer version available] (you’re 11 commits behind) — [Update Now] appearing. If I update, Sickrage wont restart afterwards.


#17

So neither one of you can install Docker CLI ?


#18

No, Docker (CE CLI v 17.12.1-ml1) did not install correctly for me. Either with Sickrage or when I tried from the app store.


#19

What version of ReadyNAS you using ?


#20

RN312 running 6.10.0-T181


#21

One thing tho, in reference to the post How to know you're using an OFFICIAL version of SiCKRAGE

I dont think the version I install from the RN app store (2018.02.17-ml0) passes any of those tips…is it mean to?


#22

That would be correct, the version that is in the RN app store is not official and is not supported here.
If you could grant me SSH access to you’re install I could take a look and see whats going on with Docker CLI ?


#23

Are you running beta ReadyNASOS then ? I’d suggest dropping back to stable if you can, I’ll start testing on beta right now to see what might be causing the issue


#25

I’m running OS6 v 6.9.4. It is the production version.

I have two RN516’s Tomorrow (10/15/18), I will open the necessary ports of the secondary backup (which does not run any apps currently…it just comes on once a night to backup the other NAS). I’ll need to do a few more bits of configuration such as changing the power cycle, making sure my old DDNS account is working correctly, etc. I’ll be able to send you SSH log-in info after that.


#26

I’ve successfully installed the new version of SR for ReadyNAS on my 316 and Docker CLI was also installed (although there is not an option to “Launch” Docker, it just says it’s “on”). I’ve been able to configure SR and add shows. When I changed a skipped episode to wanted, I got the notification that the show episode was snatched, but it was not added to my uTorrent client. Am I missing a setting somewhere?

Your support has been fantastic! Thanks a lot!


#27

When you go into the search client settings and test your setup what does it say ?


#28

Yep, dyslexia strikes again. Thanks again! Sorry… :frowning:


#29

I just got it working on my second (mostly virgin) NAS RN516. It installed Docker and the app and the refreshed interface looks GREAT.

So, now, I just need to determine why it won’t install on my primary RN516. The primary unit is quite busy and resource starved. It runs CouchPotato, Deluge, Headphones, Open VPN, Plex, Resilio Sync, SABnzbd, and Sickrage all with 4GB of memory. Oh, did I mention that it also is doing H265 encoding most of the day as a part of the NZBtoMedia scripts?

I’ll start mirroring the setup on my secondary NAS to match the primary and will hopefully find the combination that makes it finally unable to load Sickrage. I’m really loving the new look so I’m hoping it will be possible to get it running on the primary.

Thanks!


#30

Your primary RN516 is running stable version of ReadyNAS-OS ?
Also is there enough space left on the device to do the install, just had to ask :slight_smile:


#31

Yes, I’m running the production version of OS6 and I keep all my system volumes small by moving databases like Plex to external locations. :slight_smile:

Ok…so, after using command line to delete all previous installations that were “stuck” and rebooting copiously, I was able to install the Docker then install the new SR. It’s up and running…and all my other apps are loading and fine.

So, I think I’m good to go…I am having that log-in error (have registered and can log in to this forum but no love on the app) but I’ll tackle that one myself or under a separate thread.

Thank you for all your help!


#32

I appear to be having the same problem described in this thread. I am running 6.9.4 on a ReadyNAS 214 device.

I was running (I think) the original version that I installed off the list of apps on my ReadyNAS server. Logged on to my Sickrage site this week and it told me that it was out of date. I’ll be honest, I’m not exactly sure what I did, but I think I chose to update the version. Since then, it won’t start, even after reboot.

I went to the How to Install on ReadyNAS site and downloaded the most recent version (2018.10.13). Trying to install, I get the “Application sickrage cannot be installed.” I don’t know where to get the original version to try and reinstall it. Obviously I’d like the most recent version.

I cannot give you access to my box, but I can try some things. Just not sure what to do from here. Can you give me some guidelines. I can send an email if that would be easier.


#33

Did you first uninstall the old one ?


#34

I did not explicitly uninstall the original version. It got uninstalled after I tried to install the version from the page How to install on ReadyNAS. The only directory out there now is /apps/sickrage/app-config. Not sure if all my data is still out there or not.

I have made a backup of that app-config directory now. Should I delete that directory and try installing from scratch? And should I try to install from the link above? When I go to the Apps tab on the ReadyNAS Admin page, the Sickrage app doesn’t appear under either Installed Apps or Available Apps.


#35

Renamed the directory to /apps/sickrage_old, tried a re-install of 2018.10.13. Same error: “cannot install application sickrage”. Any log files I can look at somewhere that tell me what it tried to do and what it couldn’t do? I poked around a bit and didn’t find anything helpful.


#36

IIS problem, permisions in the web settings had the same prob with win server 2012 r2.
IIS [Internet Information Services ]