SR keeps failing to run

The time in Sickrage seems to be an hour ahead. Is that normal?

image

This appears to be related to my issue of SR not loading sometimes. When I attempt to run the python script I get the following.


pip install -U tzlocal, seems to fix the issue for a few hours, then SR will fail to run again.

Do you not leave SR running ?

I do but it stops randomly usually after a few hours. There doesn’t appear to be anything useful in the logs. These are the logs that I’m checking. Is there another place I could look?

/root/.sickrage/logs/sickrage.log
/root/.sickrage/logs/sickrage.error.log
/home/pi/.sickrage/logs/sickrage.log
/home/pi/.sickrage/logs/sickrage.error.log
/opt/sickrage/logs/sickrage.error.log.4
/opt/sickrage/logs/sickrage.log.1
/opt/sickrage/logs/sickrage.log.5
/opt/sickrage/logs/sickrage.log.3
/opt/sickrage/logs/sickrage.error.log.3
/opt/sickrage/logs/sickrage.error.log.5
/opt/sickrage/logs/sickrage.error.log.2
/opt/sickrage/logs/sickrage.log
/opt/sickrage/logs/sickrage.log.4
/opt/sickrage/logs/sickrage.log.2
/opt/sickrage/logs/sickrage.error.log.1
/opt/sickrage/logs/sickrage.error.log

After a few hours this is what I get when trying to access it:

Email me yours logs please

This started happening again. I get below output when I try to run sickrage.py:

Traceback (most recent call last):
File “/opt/sickrage/sickrage/init.py”, line 318, in main
app.start()
File “/opt/sickrage/sickrage/core/init.py”, line 176, in start
self.scheduler = TornadoScheduler()
File “/usr/local/lib/python2.7/dist-packages/apscheduler/schedulers/base.py”, line 83, in init
self.configure(gconfig, **options)
File “/usr/local/lib/python2.7/dist-packages/apscheduler/schedulers/base.py”, line 122, in configure
self._configure(config)
File “/usr/local/lib/python2.7/dist-packages/apscheduler/schedulers/tornado.py”, line 43, in _configure
super(TornadoScheduler, self)._configure(config)
File “/usr/local/lib/python2.7/dist-packages/apscheduler/schedulers/base.py”, line 694, in _configure
self.timezone = astimezone(config.pop(‘timezone’, None)) or get_localzone()
File “/usr/local/lib/python2.7/dist-packages/tzlocal/unix.py”, line 165, in get_localzone
_cache_tz = _get_localzone()
File “/usr/local/lib/python2.7/dist-packages/tzlocal/unix.py”, line 90, in _get_localzone
utils.assert_tz_offset(tz)
File “/usr/local/lib/python2.7/dist-packages/tzlocal/utils.py”, line 38, in assert_tz_offset
raise ValueError(msg)
ValueError: Timezone offset does not match system offset: 0 != 3600. Please, check your config files.