Sickrage on RaspberyPi3 - cannot login - constant redirect

Hi,

It seems that since 2-3 days ago (maybe following an upgrade of the app), everytime I try to login into the Sickrage app over Chrome, it does not authenticate and returns to the same login page.
It was working about 2 days ago.
I tried clearing the cache and browsing data and starting fresh. The sickrage domain is cleared within Pi-Hole.
I can provide logging data if needed, just I do not know what.
This is the login address (https://auth.sickrage.ca/auth/realms/sickrage/protocol/openid-connect/auth?response_type=code&client_id=sickrage-app&redirect_uri=http%3A%2F%2F192.168.0.108%3A8081%2Flogin&scope=profile+email+offline_access) and after entering my email and pass - it re-directs to the same address.
Here is the status of the Sickrage daemon:
[email protected]:~$ sudo service sickrage status

  • sickrage.service - SickRage Daemon
    Loaded: loaded (/etc/systemd/system/sickrage.service; enabled; vendor preset: enabled)
    Active: active (running) since Sun 2020-01-12 11:39:05 EET; 23s ago
    Process: 14058 ExecStart=/usr/bin/python3 /opt/sickrage/SiCKRAGE.py -q --daemon --nolaunch --datadir=/opt/sickra
    CGroup: /system.slice/sickrage.service
    |-14074 /usr/bin/python3 /opt/sickrage/SiCKRAGE.py -q --daemon --nolaunch --datadir=/opt/sickrage
    |-14096 git remote update
    |-14097 git fetch --multiple --all
    |-14098 git fetch --append origin
    `-14099 git-remote-https origin https://git.sickrage.ca/SiCKRAGE/sickrage

Jan 12 11:38:47 kodi systemd[1]: Starting SickRage Daemon…
Jan 12 11:39:05 kodi systemd[1]: Started SickRage Daemon.
lines 1-13/13 (END)

Please update to the latest version 9.4.197 and then log out and back in, should resolve the issue.

Hi, and thank you for the speedy response.
How can I update by not using the GUI? from SSH

git pull from inside the install folder should do the trick :slight_smile:

if that doesn’t fix it after the update then try deleting the cache.db file and restarting the app.

git pull from within the folder states that it’s already up to date, what cache file should I delete:
[email protected]:/opt$ ls sickrage/ COPYING.txt cache.db-shm config.ini_20191217_202412.bak manifests setup.py Dockerfile cache.db-shm.v3 crowdin.yaml package.json sickrage MANIFEST.in cache.db-wal dist privatekey.pem sickrage.egg-info README.txt cache.db-wal.v3 docker-compose.yml privatekey.pem_20191217_202412.bak sickrage.pid SiCKRAGE.py cache.db.v3 logs readme.md src backup cache.db_20191217_202412.bak main.db requirements-dev.txt tests build cache_20191217_202412.bak main.db-shm requirements.txt webpack.config.js cache changelog.md main.db-wal runscripts yarn.lock cache.db config.ini main.db_20191217_202412.bak setup.cfg

just do rm -fr cache.db*

ran the command, restarted the service and it’s still the same issue :frowning:
[email protected]:/opt/sickrage$ sudo rm -fr cache.db*
[email protected]:/opt/sickrage$ sudo service sickrage restart
[email protected]:/opt/sickrage$ sudo service sickrage status

  • sickrage.service - SickRage Daemon
    Loaded: loaded (/etc/systemd/system/sickrage.service; enabled; vendor preset: enabled)
    Active: active (running) since Sun 2020-01-12 11:59:46 EET; 18s ago
    Process: 16525 ExecStart=/usr/bin/python3 /opt/sickrage/SiCKRAGE.py -q --daemon --nolaunch --datadir=/opt/sickrage (code=exited, status=0/S
    CGroup: /system.slice/sickrage.service
    |-16544 /usr/bin/python3 /opt/sickrage/SiCKRAGE.py -q --daemon --nolaunch --datadir=/opt/sickrage
    |-16564 git remote update
    |-16565 git fetch --multiple --all
    |-16566 git fetch --append origin
    `-16567 git-remote-https origin https://git.sickrage.ca/SiCKRAGE/sickrage

Jan 12 11:59:31 kodi systemd[1]: Starting SickRage Daemon…
Jan 12 11:59:46 kodi systemd[1]: Started SickRage Daemon.

Any chance you can grant me ssh access so I can take a further look ?

sure, give me a sec to forward the SSH port and I will give you my ext IP

Please private message me that info and if you can also forward port for sickrage also so I can test logins, thanks!

done, and thank you very much

unable to SSH or access SR

It’s solved now - thank you very much for the great assistance.
The issue was solved and pushed through an update. Update your sickrage instance from the sickrage folder directly - sudo git pull - and you should solve it if it happens to you too.