OpenSSL not available, please install for better requests validation

After using SiCKRAGE for ages and being so happy about it that it just worked in the background I noticed that in fact it had stopped working properly, mostly due to the fact that the Git repo and everything moved and I had not upgraded in ages. So I did a re-install on my 8 year old QNAP ARMv5 NAS and it was an adventure to say the least. Not having a number of -dev packages on Entware-ng, a stupidly small /tmp partition and all kinds of other weird things. Anyway, I finally managed to compile and install everything and it works just perfectly. Except for one thing and I can’t figure this one out:

Right after “Starting QSickRage” I get

OpenSSL not available, please install for better requests validation: `https://pyopenssl.readthedocs.org/en/latest/install.html`

pyopenssl is installed (18.0.0)
libopenssl is installed (1.0.2n-1)
python-openssl is installed (2.7.14-5)
and of course other stuff such as cryptography and so on.

So what am I missing here? Why do I get this message? I remember it occurring on my old SiCKRAGE install due to libopenssl being < 1.0.0 back then, but 1.0.2 should be fine now. Any ideas would be greatly appreciated.

Did you ever figure this out,
I know the post is old but I have this problem

Curious but did you install with pip3 or pip ?