Fresh install won't start. error: No module named 'apscheduler'

Hi.
I’ve installed a fresh Win10 VM on my synology. Installed python 3.9, updated to pip v20 (latest).
Downloaded and installed SR today (10/10/20) from website. In installation i input my user+pass and path of python3 : C:\Program Files\Python39
After installation SiCKRAGE service won’t start. From CMD I tried installing requirements again, and then to run SR. But still run into errors and SR wont start.
Attached the cmd window.

What can i do??? thanks!!

C:\SiCKRAGE>pip3 install --no-deps -r c:\sickrage\requirements.txt
Ignoring cryptography: markers 'python_version < "3.6"' don't match your environment
Ignoring dogpile.cache: markers 'python_version < "3.6"' don't match your environment
Ignoring feedparser: markers 'python_version < "3.6"' don't match your environment
Ignoring lxml: markers 'python_version < "3.6"' don't match your environment
Ignoring Pint: markers 'python_version < "3.6"' don't match your environment
Ignoring stevedore: markers 'python_version < "3.6"' don't match your environment
Collecting alembic==1.4.2
  Using cached alembic-1.4.2.tar.gz (1.1 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting appdirs==1.4.4
  Using cached appdirs-1.4.4-py2.py3-none-any.whl (9.6 kB)
Collecting APScheduler==3.6.3
  Using cached APScheduler-3.6.3-py2.py3-none-any.whl (58 kB)
Collecting arrow==0.15.8
  Using cached arrow-0.15.8-py2.py3-none-any.whl (49 kB)
Collecting asn1crypto==1.4.0
  Using cached asn1crypto-1.4.0-py2.py3-none-any.whl (104 kB)
Collecting attrs==19.3.0
  Using cached attrs-19.3.0-py2.py3-none-any.whl (39 kB)
Collecting babelfish==0.5.5
  Using cached babelfish-0.5.5.tar.gz (90 kB)
Collecting beautifulsoup4==4.9.1
  Using cached beautifulsoup4-4.9.1-py3-none-any.whl (115 kB)
Collecting bencode3==0.1.0
  Using cached bencode3-0.1.0.tar.gz (2.1 kB)
Collecting CacheControl==0.12.6
  Using cached CacheControl-0.12.6-py2.py3-none-any.whl (19 kB)
Collecting certifi==2020.6.20
  Using cached certifi-2020.6.20-py2.py3-none-any.whl (156 kB)
Collecting cffi==1.14.1
  Using cached cffi-1.14.1.tar.gz (468 kB)
    ERROR: Command errored out with exit status 1:
     command: 'c:\users\sickuser\appdata\local\programs\python\python39\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\SickUser\\AppData\\Local\\Temp\\pip-install-3m2t2tp9\\cffi\\setup.py'"'"'; __file__='"'"'C:\\Users\\SickUser\\AppData\\Local\\Temp\\pip-install-3m2t2tp9\\cffi\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:\Users\SickUser\AppData\Local\Temp\pip-pip-egg-info-4ntq1p2e'
         cwd: C:\Users\SickUser\AppData\Local\Temp\pip-install-3m2t2tp9\cffi\
    Complete output (19 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\SickUser\AppData\Local\Temp\pip-install-3m2t2tp9\cffi\setup.py", line 131, in <module>
        if sys.platform == 'win32' and uses_msvc():
      File "C:\Users\SickUser\AppData\Local\Temp\pip-install-3m2t2tp9\cffi\setup.py", line 109, in uses_msvc
        return config.try_compile('#ifndef _MSC_VER\n#error "not MSVC"\n#endif')
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\command\config.py", line 225, in try_compile
        self._compile(body, headers, include_dirs, lang)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\command\config.py", line 132, in _compile
        self.compiler.compile([src], include_dirs=include_dirs)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\_msvccompiler.py", line 323, in compile
        self.initialize()
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\_msvccompiler.py", line 220, in initialize
        vc_env = _get_vc_env(plat_spec)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\site-packages\setuptools\msvc.py", line 314, in msvc14_get_vc_env
        return _msvc14_get_vc_env(plat_spec)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\site-packages\setuptools\msvc.py", line 268, in _msvc14_get_vc_env
        raise distutils.errors.DistutilsPlatformError(
    distutils.errors.DistutilsPlatformError: Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio": https://visualstudio.microsoft.com/downloads/
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.



C:\SiCKRAGE>python SiCKRAGE.py
Traceback (most recent call last):
  File "C:\SiCKRAGE\sickrage\__init__.py", line 344, in main
    from sickrage.core import Core
  File "C:\SiCKRAGE\sickrage\core\__init__.py", line 36, in <module>
    from apscheduler.schedulers import SchedulerNotRunningError
ModuleNotFoundError: No module named 'apscheduler'

C:\SiCKRAGE>???

It appears you need to install MS Visual C++ 14.0, can you do that and let me know if that resolved the issue ?

Hi my friend, I’ve installed both Visual C++ Redistributable v14 and v2019 from these links:
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
https://www.microsoft.com/en-us/download/confirmation.aspx?id=48145

Did reboot, and try to install the requirements.txt again.

But still the same error and red text appears:

C:\Users\SickUser>pip3 install --no-deps -r c:\sickrage\requirements.txt
Ignoring cryptography: markers 'python_version < "3.6"' don't match your environment
Ignoring dogpile.cache: markers 'python_version < "3.6"' don't match your environment
Ignoring feedparser: markers 'python_version < "3.6"' don't match your environment
Ignoring lxml: markers 'python_version < "3.6"' don't match your environment
Ignoring Pint: markers 'python_version < "3.6"' don't match your environment
Ignoring stevedore: markers 'python_version < "3.6"' don't match your environment
Collecting alembic==1.4.2
  Using cached alembic-1.4.2.tar.gz (1.1 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting appdirs==1.4.4
  Using cached appdirs-1.4.4-py2.py3-none-any.whl (9.6 kB)
Collecting APScheduler==3.6.3
  Using cached APScheduler-3.6.3-py2.py3-none-any.whl (58 kB)
Collecting arrow==0.15.8
  Using cached arrow-0.15.8-py2.py3-none-any.whl (49 kB)
Collecting asn1crypto==1.4.0
  Using cached asn1crypto-1.4.0-py2.py3-none-any.whl (104 kB)
Collecting attrs==19.3.0
  Using cached attrs-19.3.0-py2.py3-none-any.whl (39 kB)
Collecting babelfish==0.5.5
  Using cached babelfish-0.5.5.tar.gz (90 kB)
Collecting beautifulsoup4==4.9.1
  Using cached beautifulsoup4-4.9.1-py3-none-any.whl (115 kB)
Collecting bencode3==0.1.0
  Using cached bencode3-0.1.0.tar.gz (2.1 kB)
Collecting CacheControl==0.12.6
  Using cached CacheControl-0.12.6-py2.py3-none-any.whl (19 kB)
Collecting certifi==2020.6.20
  Using cached certifi-2020.6.20-py2.py3-none-any.whl (156 kB)
Collecting cffi==1.14.1
  Using cached cffi-1.14.1.tar.gz (468 kB)
    ERROR: Command errored out with exit status 1:
     command: 'c:\users\sickuser\appdata\local\programs\python\python39\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\SickUser\\AppData\\Local\\Temp\\pip-install-ewvoj2_h\\cffi\\setup.py'"'"'; __file__='"'"'C:\\Users\\SickUser\\AppData\\Local\\Temp\\pip-install-ewvoj2_h\\cffi\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:\Users\SickUser\AppData\Local\Temp\pip-pip-egg-info-pjrkt5sa'
         cwd: C:\Users\SickUser\AppData\Local\Temp\pip-install-ewvoj2_h\cffi\
    Complete output (19 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\SickUser\AppData\Local\Temp\pip-install-ewvoj2_h\cffi\setup.py", line 131, in <module>
        if sys.platform == 'win32' and uses_msvc():
      File "C:\Users\SickUser\AppData\Local\Temp\pip-install-ewvoj2_h\cffi\setup.py", line 109, in uses_msvc
        return config.try_compile('#ifndef _MSC_VER\n#error "not MSVC"\n#endif')
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\command\config.py", line 225, in try_compile
        self._compile(body, headers, include_dirs, lang)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\command\config.py", line 132, in _compile
        self.compiler.compile([src], include_dirs=include_dirs)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\_msvccompiler.py", line 323, in compile
        self.initialize()
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\distutils\_msvccompiler.py", line 220, in initialize
        vc_env = _get_vc_env(plat_spec)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\site-packages\setuptools\msvc.py", line 314, in msvc14_get_vc_env
        return _msvc14_get_vc_env(plat_spec)
      File "c:\users\sickuser\appdata\local\programs\python\python39\lib\site-packages\setuptools\msvc.py", line 268, in _msvc14_get_vc_env
        raise distutils.errors.DistutilsPlatformError(
    distutils.errors.DistutilsPlatformError: Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio": https://visualstudio.microsoft.com/downloads/
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

C:\Users\SickUser>

Any idea?

If you want I can teamviewer onto you’re PC and try to resolve this, you would need to private message me the login details.

Sent! Pls dont spend too much of your time on it :slight_smile: