File "/opt/sickrage/sickrage/__init__.py", line 260, in main


#1

Hi,

Since last update, sickrage is not launching anymore:
systemctl status sickrage

● sickrage.service - LSB: starts instance of SickRage
Loaded: loaded (/etc/init.d/sickrage; generated; vendor preset: enabled)
Active: active (exited) since Sun 2018-11-04 12:13:29 CET; 47min ago
Docs: man:systemd-sysv-generator(8)
Process: 6124 ExecStop=/etc/init.d/sickrage stop (code=exited, status=1/FAILURE)
Process: 6132 ExecStart=/etc/init.d/sickrage start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/sickrage.service

nov. 04 12:13:22 raspberrypi systemd[1]: Starting LSB: starts instance of SickRage…
nov. 04 12:13:22 raspberrypi sickrage[6132]: Starting SickRage
nov. 04 12:13:29 raspberrypi sickrage[6132]: Traceback (most recent call last):
nov. 04 12:13:29 raspberrypi sickrage[6132]: File “/opt/sickrage/sickrage/init.py”, line 260, in main
nov. 04 12:13:29 raspberrypi sickrage[6132]: app.quite = args.quite
nov. 04 12:13:29 raspberrypi sickrage[6132]: AttributeError: ‘Namespace’ object has no attribute ‘quite’
nov. 04 12:13:29 raspberrypi systemd[1]: Started LSB: starts instance of SickRage.

I would need help to correct the launching please.

Thanks.

O.


#2

Any fixes yet? I have the same problem on a Synology NAS.


#3

I have the same problem.

● sickrage.service - SickRage Daemon
Loaded: loaded (/etc/systemd/system/sickrage.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Sun 2018-11-04 15:51:32 CET; 5min ago
Process: 10188 ExecStart=/usr/bin/python /opt/sickrage/SiCKRAGE.py -q --daemon --nolaunch --datadir=/opt/sickrage (code=exited, status=0/SUCCESS)

nov 04 15:51:25 jensserver systemd[1]: Starting SickRage Daemon…
nov 04 15:51:32 jensserver python[10188]: Traceback (most recent call last):
nov 04 15:51:32 jensserver python[10188]: File “/opt/sickrage/sickrage/init.py”, line 260, in main
nov 04 15:51:32 jensserver python[10188]: app.quite = args.quite
nov 04 15:51:32 jensserver python[10188]: AttributeError: ‘Namespace’ object has no attribute ‘quite’
nov 04 15:51:32 jensserver systemd[1]: Started SickRage Daemon.

FIX: It’s a mistake in the file opt/sickrage/sickrage/init.py on line 260 -> it says app.quite = app.quite but it should be app.quiet = app.quiet, try changing this and restart the service, it should work


#4

Fix worked like a charm. thanks!


#5

Actually you should just perform a git pull, this was a typo that was put out in one of the releases last night by mistake but fixed shortly afterwards, it was just luck of the draw that you took the update before I had time to correct it causing this startup issue, I apologize for that.


#6

No worries. Thanks for the info. I just pulled the latest package.


#7

Many thanks ! It is working again.


#8

Hi,

The solution above was simplier but thanks.
I should stop the auto update (will seek how to do) in order to avoid this kind of stuff.
And for example, the providers py files are auto updated with wrong provider sites wich means that at each update I have to update py files… will create another topic for that.

Cheers,
O.


#9

I’ll be implementing a way to add custom urls for all providers soon enough