"Convert provider torrent magnetic links to torrent files" doesn't work


I use SR in my Synology NAS since a few years. Since I upgrade to the Python 3 version, I am not able to get torrent files in my blackhole folder. Instead of that, they are always “magnet” versions.

Unfortunately blackhole method doesn’t work with .magnet in Download Station, so I have a bunch of “Snatched” episodes and the same number of files waiting in the folder.

I know about the “Convert provider torrent magnetic links to torrent files” option, but it doesn’t matter whether it is enabled or not. File is always downloaded as .magnet.

Any comment/advise is welcomed!

What version are you currently on of SR ? and what torrent provider are you using ?
Also why use the blackhole feature when there is a Synology client built-in ?

  • SR version: 9.4.223
  • Torrent provider: I have tried with several ones, always with the same results. But anyway, SR should convert it to .torrent with that option enabled, isn’t it? Maybe I am misunderstanding this feature…
  • Why do I use blackhole?: Probably because of historical reasons… In other words, it worked for years so I have never worried about it. I remember I tried some time ago to switch to the other method but I always got error “DownloadStation: Unable to send Torrent”…

I can certainly take a look into why its creating .magnet when it should be .torrent, been busy with designing the new web interface so slowed down on fixing bugs, I’ll take a look later tonight.

Hello @echel0n

Have you found out anything about it?


I’ll look at this now, been consumed with the new UI buidling.

Going over the code it would appear nothing is wrong, if SR can’t lookup the magnet torrent hash and find a match in our API it will not convert the magnet URL to a torrent file but instead creates a magnet file which does work with most torrent software, I personally have had no issues with this. In the past we would lookup the hash to convert it through external sources but those sources over time became more and more unreliable.

I would suggest retrying DownloadStation with SR and see if its now working, if it still is not I can take a look into resolving that issue.


Resurrecting this thread , Ive just also installed Sickrage on Synology DSM7 using Docker, and it ONLY seems to download Magnet files, and then not convert at all to torrent.
I cant get any program to then use the magnet files…Download station Or Folx on the Mac…they say the file isn’t recognised which is odd!
Is there something I can do …?
Right now I have to copy all the text from the magnet file and manually add it to Download manager as a task …not ideal
Any help appreciated


Same issue here as @wakevortex. Are there any workarounds or is this on the radar to be fixed any time soon?

What version of SR are you using?