Can't Open Web Interface

Since maybe a few days ago, I’ve been unable to open the web interface.

Don’t seem to get any errors showing up in the logs (just nothing)

Tried restoring backups, but don’t seem to have early enough backups.

I run this on port 8081 normally but this doesn’t seem to be connecting.
I can see sickrage is actually running and doing things, just can’t connect to the web interface…

Any thoughts?

Running on Windows 10 fwiw

I am having the same issue. This is what my browser says. I’ve tried it on Chrome, Firefox and IE same error across the board.

“Unable to connect
Firefox can’t establish a connection to the server at localhost:8081.”

Have you tried downloading the new setup file from the website to update ?

Not as yet, but let me give that a go

Ok, so grabbed the latest setup.exe, and no dice (though it seemed to update a version)

Same issue also on Windows 10.
localhost refused to connect
ran the setup. It installed Python (again?) ran it a 2nd time and it updated version of SickRage.
Restarted the service and web interface will not load /home or /config

I used the windows uninstall then ran the setup again but it still won’t start. Thanks!

Here also, last week i had the first problem, but a hard reboot fixed it hen, today the same problem, but failed, also removed all and reinstalled the new version, but still no connection

If someone wants to install TeamViewer and private message me their ID and password, I can remote on and take a further look to.fix this issue.

OK, I was able to track the issue down to misc files that are not being removed on updates, depending on the file this can cause a import exception, since the code is still functional in the background I should be able to resolve this with an update. Most likely I will need to code a file integrity checker to fire off at startup to compare against a checksum list and remove any invalid files it finds.

I’ll get to work on this shortly and then reply back once I’ve pushed the update out, I did already update the Windows installer to remove the files on updates so if you can’t wait you can always re-download the latest setup.zip from the website and re-install.

Thanks!

Just came back, saw SickRage working, you did a great job, hope this will help you fix it for everybody :smiley:

1 Like

I’m new to SickRage and just downloaded the new setup from the website tonight, but still receiving an error when connecting to localhost. Any other advice?

@yogrark can you check and see if this file is present C:\SiCKRAGE\sickrage\core\webserver\views\home\status.mako

If it is please remove it and restart SR and let me know.

Thanks!

Killing status.mako got it working again cheers

Yup, next release will perform a cleanup on startup to prevent this issue from occurring ever again

Oh, no. Mine will still not start.

  • I do not have status.mako
  • I downloaded the windows setup.zip from https://www.sickrage.ca/
  • I (backed up and) deleted the home folder then repaired from the installer
  • I restarted the Sickrage service

Still localhost refused to connect

What can I try next?

Ok, despite your fix, SickRage still running but keeps growing in memory, I had to restart service cause it was eating 10Gb of my memory. I could add 16Gb more memory, but that’s not a viable solution :wink:

Well, I didn’t reboot my computer since you worked on it, so I’ll try and see if it’s still eating memory and I’ll keep you updated.

I’m pushing a fix now for the web-ui, it’ll cleanup all unwanted files on startup after it updates, also several other fixes for invalid episodes being created due to premature saving to database.

OK. Thanks. What do I do? Do I need to download again? uninstall? reinstall? repair?

Please stand by, I am working on a fix for this now, I will reply back later with next steps.