Can't add custom torrent provider

RARBG is no longer working for a long time. I’m trying to add a custom torrent provider to make RARBG work, but I’m having troubles or I don’t know the proper way to go.

This is what I’m doing:

Settings → Search Providers → Custom Torrent Providers

Provider Name: (WHATEVER)
RSS URL: https://rarbg.to/rss.php
Cookies: (Blank)
Search element: title

When I click Add, I get an error message: " Error when trying to load RSS: ‘entries’ "

I have googled with no luck and I can’t make this work. Anybody can help or tell me what I’m doing wrong?

Thanks in advance!

Regards,
JC

What do you mean RARBG is not working, there is no need to add a custom torrent for them.

I mean I’m getting this errors in the log file since months:

2022-09-04 16:23:02 SEARCHQUEUE-40HIK5QEMP-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 16:22:48 SEARCHQUEUE-T3E3SDX5AZ-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 16:22:46 SEARCHQUEUE-4KL1G60CJW-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 16:22:45 SEARCHQUEUE-QJ30HM6CIO-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 16:22:45 SEARCHQUEUE-4G20P20I02-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 15:50:47 RSSCACHE-UPDATER::RARBG::Unable to connect to provider
2022-09-04 15:48:18 SEARCHQUEUE-0B435KQIGA-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 15:48:17 SEARCHQUEUE-116JVA5OQX-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 15:48:17 SEARCHQUEUE-13SD7O02EH-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 15:48:17 SEARCHQUEUE-K35KE6GY5P-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 15:48:17 SEARCHQUEUE-S2APZ40KDD-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 15:20:35 RSSCACHE-UPDATER::RARBG::Unable to connect to provider
2022-09-04 14:53:41 SEARCHQUEUE-41Q52F6VK2-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:53:22 SEARCHQUEUE-RH6V522Q31-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:53:07 SEARCHQUEUE-R0OYC42JLU-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:53:06 SEARCHQUEUE-G6HS244TE2-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:52:59 SEARCHQUEUE-13RQ3JOX6D-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:50:35 RSSCACHE-UPDATER::RARBG::Unable to connect to provider
2022-09-04 14:46:50 SEARCHQUEUE-12NIUXF0MN-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:46:30 SEARCHQUEUE-02JX535OT0-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:46:15 SEARCHQUEUE-KREMOTBI0P-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:46:14 SEARCHQUEUE-GA4732HUOJ-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:46:07 SEARCHQUEUE-N2KH1N2EFB-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:39:57 SEARCHQUEUE-X122DCEGDL-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:39:36 SEARCHQUEUE-0UGMV1MG6S-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:39:21 SEARCHQUEUE-J3EQ1X60PE-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider
2022-09-04 14:39:20 SEARCHQUEUE-S13JWKNH0P-BACKLOG-279121-TheTVDB::[Rarbg]::Unable to connect to provider

I get this warning every day (dozens of them) with that text you can read “Unable to connect to provider”. I assumed it’s not working… Or I don’t understand that warning…

what version of SR are you on ?

Sickrage for Windows version 10.0.69

how many shows do you currently have in SR ?

fourteen shows only_________

could you please create a backup in SR and then send that to [email protected] so I can further go over your settings, thanks.

1 Like

Done. I’ve just sent the json config files by email

1 Like

Did you have some time to check the json config files I sent by email? :slight_smile:

I’ve received them, I have not had time to get to them just yet, been busy at work IRL, will get to them most likely this weekend.

Thank you so much! Please, drop me a quick message if you know why the hell RARBG doesn’t work for me (or it works but shows that warning message all the time continuously).

THANKS!!!

What do you get in a browser when you go to http://torrentapi.org/pubapi_v2.php on the same system sickrage runs on ?

It seemed that something was wrong with my SickRage. I’ve just uninstalled and reinstalled again and tested with RARBG as the only provider and now it works and no Warning error received.

Thanks anyway.

1 Like

yeah, when I restored your backups to test and check config settings, I could not find anything that stood out as the cause, going over the code I pulled their API URL which is why I asked if you could reach that site or not, glad its fixed.