Cannot login keeps going back to login

Hi, I have not been able to login it keeps looping and I get no errors in logs. I have tried a full reinstall and the same issue occurs. Please help.

What version are you on please ?

Windows and fresh install 12 hours ago. Will need to check exact version but at a guess the latest master branch

Same problem, latest master branch, under linux.
APP VERSION:[9.4.199]
CONFIG VERSION:[v15]
DATABASE VERSION:[v10]
DATABASE TYPE:[sqlite]

On sartup i have this warning.
WARNING::CORE::‘Invalid token error, please re-authenticate by logging out then logging back in from web-ui’
edit: removed cache-db files, no more warning on startup, still looping on login form.

Hi, it is 9.4.199 and was freshly installed yesterday as a last resort. Seems to be around authentication passing back.

It appears to be running just cannot login as it keeps looping on the login screen

Are you able to grant me teamviewer access ?

Sorry firewalled off. What do you need to see? I access my instance it redirects to https://auth.sickrage.ca/auth/realms/sickrage/protocol/openid-connect/… and I login and it goes straight back to this again with no messages. If I use incorrect password it tells me but that is it.

Need to debug the code, what browser are you using ?

Chrome but just tried IE and it worked. I had cleared my browser history on chrome but that has not worked. So not sure what is cached on chrome or configured to cause issue on both a windows and android device

Including cookies ? did you try incognito mode ?

I tested incognito same issue and yes to cookies being cleared

I suspect this has to do with the length of the cookie being stored causing an issue for chrome, oddly I’ve only seen one other person with the same issue, without having remote access to test on you’re system I can’t really resolve this issue right away.

I now have this in the logs. DEBUG::CORE::KeycloakClientError(‘400 Client Error: Bad Request for url: https://auth.sickrage.ca/auth/realms/sickrage/protocol/openid-connect/token’)

The issue is the same for me, in either chromium or firefox
clearing cache and cookies or incognito changes nothing.

Edit: just tried to connect with chrome on android device for the very first time (so nothing stored), same issue.

Edit2: tried a new install of sickrage (git clone) with empty DB. (db is stored in installation directory right ?) nothing changes, it loops on login screen. called pip install -r requirements.txt, a few updates were made, nothing changes.

Edit3: this is the url redirection for local login:
https://auth.sickrage.ca/auth/realms/sickrage/protocol/openid-connect/auth?response_type=code&client_id=sickrage-app&redirect_uri=http%3A%2F%2F192.168.0.7%3A8081%2Flogin&scope=profile+email+offline_access

I have noticed something strange, when i start sickrage, it tells me
INFO::CORE::SiCKRAGE :: URL:[http://192.168.0.30:8081]
which is wrong, the correct host is 192.168.0.7
Can it be a good lead ?

@duloid
Are you able to access SR WebUI from http://192.168.0.7:8081 ?

yes, i can log into my account.
forum, main page and all.

https://auth.sickrage.ca/auth/realms/sickrage/account/ works just fine (except it does not remember me)

Edit: not sure i understand your question, i mean sickrage.ca works fine.
My local sickrage http://192.163.0.7:8081 redirects me on login and does not work if sickrage is off.
Tried with http://localhost:8081, does the same.

ok so to confirm, you can access the app and log into it just fine using 192.168.0.7 ?

I can access my local sickrage, that redirect me to login, wich is looping so i can’t log and can’t access the webui.

And you’re install is running on Windows ?